Can’t install WordPress plugins and themes via dashboard – a fix

On 28 November, 2009 by Carol

wordpressI’ve had some Wordprress installation problems with version 2.8.5 and with 2.8.6 when trying to install new plugins and themes via WP dashboard, as well as upgrading.

The problem:
Downloading the file works perfect and without errors but it stops when it has to unpack.
Basically, nothing happens.
I can see the zipped file on my ftp server, but this same file should be automatically unzipped and installed….which it doesn’t.

WordPress support forums has some topics on this, but people actually have errors; they do not get a black installation page after.

The fix i found that works for me:

As usual, a memory issue which can easily be fixed.
By default, most hosts limit the memory to 32MB, but the workaround in WordPress is to modify wp_settings.php on line 13 and change WP_MEMORY_LIMIT from 32 MB to 64MB.

Find the file into your WordPress root directory, back it up, make the change, save and upload.

if ( !defined(‘WP_MEMORY_LIMIT’) )
define(‘WP_MEMORY_LIMIT’, ’32M’);

change to:

if ( !defined(‘WP_MEMORY_LIMIT’) )
define(‘WP_MEMORY_LIMIT’, ’64M’);

That should fix it! After making this change, i was able to install themes and plugins without a problem whatsoever.
Try installing a new theme or plugin from your dashboard.
Hope it works for you too!

  • http://twitter.com/WaterlooW Waterloo Structures

    Great job! I’ve experience the same problem about 2 days ago. I was really frustrated and ended up messing things. Then, I’ve stumbled upon your site and you have proved to me that yours is the best way. Thank you very much for this.

  • http://www.facebook.com/iggypritzker Iggy Pritzker

    In wp 3.1.3 it’s inside /wp-includes/default-constants.php
    http://www.fix-css.com/2011/06/cant-install-wp-plugins/

  • lisa

    um, I didnt back up my settings file and the change didnt work, what do i do now?

    this bit: if ( !defined(‘WP_MEMORY_LIMIT’) )
    define(‘WP_MEMORY_LIMIT’, ’32M’);
    wasnt in the file for me to change.

    but i added your code anyway, obviously not the right way :/

    • http://www.carolsvault.com/ Carol

      Hey Lisa,

      Are you sure you looked at the right file?

      The file i pointed out contains that code.

  • just guest

    it won’t work for me..
    when i try to install plugin, or themes, it alway stop. and when i refresh the browser, there no plugin or themes that i want to install.
    can you help me?

    • http://www.carolsvault.com/ Carol

      Can you contact your host and ask them about the restrictions on the server?
      Can you check and see if your htaccess file has the right permissions or even exists?

  • http://blogcraving.com/ Travis Lusk

    That seemed to do the trick. I've upped the memory limit on other blogs of mine due to some more complicated scripts running on the front end. I never realized how resource intensive the auto install/upgrade functionality is.

  • http://www.carolsvault.com/ Carol

    Changing permissions to 777 and then back to 755 helped some people.
    Try disabling all plugins at once via dashboard and try installing a new one, or updating an existing. See what happens.

    Make sure that after changing the mem. limit, you upload the right file online.

    Let me know if that helped.

    If you have the cache plugin, uninstall it and see what happens.

  • dilek

    Yes, I did. The strange thing is that I don't get an error message, just a blank screen for minutes with a toolbar message saying the data is being transfered…
    I changed the file & folder permissions to 777, WP_MEMORY_LIMIT to 64M , deleted the plugin and tried to install another one (in case that the plugin is faulty). No use.
    Is it possible that the installed theme or WordPress version 2.9.1. somehow blocks the new plugins?

  • http://www.carolsvault.com/ Carol

    Did you changed the permissions back to 755?
    It did work for some people, but didn't work for me.

  • dilek

    Unfortunately this doesn't work for me. I also tried to change the file permission to 777, but didn't help.

  • Pingback: Geek Squeaks’ of the Week (#39) « What's On My PC()

%d bloggers like this: